AnsweredAssumed Answered

is there an iMFP for Ricoh newer than 1.5.4?

Question asked by Kurt Albrecht on Nov 6, 2019
Latest reply on Nov 6, 2019 by Scott Olswold

I have a zipped folder titled MFP for Ricoh v1.5.8 but the documentation is labeled as v1.5.4.

is that correct?

Outcomes