3 Replies Latest reply on Jan 25, 2019 11:36 AM by Bill Kasper

    Issue Installing Ricoh 1.5.8 IMFP Software

    Jim Armstrng Newbie

      Hello,

       

      We are having issues installing version 1.5.8 on our Ricoh copiers.  When we try to install this version, the installer  generates an Error 0 when you try and install it to the Ricoh copiers.  I am able to install 1.5.4; however, I would like a version that takes advantage of the Smart Operations Panel interface and does not run in legacy mode as this will offer a far better user experience for people that need to type in their username and password.  I was told that Pharos would send me version 1.5.7 to see if this works as it supports the Smart Operations Panel.  So far, I have not received a link to this. 

       

      So we are on the same page, I tried installing the 1.5.8 version with no credentials; however, this version allows you to enter a Username and Password.  Due to this, I set an Admin password and entered the credentials and I am able to connect to the copier; however, after attempting to install the IMFP software I receive the Error 0.

       

      Please either let me know if there is something different that needs to be done for version 1.5.8 or let me know where I can download 1.5.7. 

       

      Thank you,

       

      Jim

        • Re: Issue Installing Ricoh 1.5.8 IMFP Software
          Scott Olswold Guide

          Jim,

           

          I'm sorry to hear that you are having installation issues with the Ricoh iMFP version 1.5.8 software. I do not think that installing a lower version will help you. I suggest you download version 1.5.9. This version has newer installation libraries, which may help you. Version 1.5.9 will install on any Ricoh Aficio on the Supported Devices list.

           

          There are two potential places to define a password on more recent devices. The first is to simply define a password for the default "admin" account. Out of the box, the "admin" account has no password. To define or change it, log onto the device's Web Image Monitor (or, WIM; the Aficio's web-based administration interface) and log in as the "admin" account. From there, choose Device Management > Configuration:

           

           

          From there, choose "Program/Change Administrator" under the "Device Settings" group. You will click the "Change" button under the "Administrator 1" group and either set or change the "admin" password:

           

           

          This password would correspond with the "Password" field when adding a device in the Ricoh iMFP Deployment applet (highlighted in green, below):

           

           

          The other password is the Remote Installation Password. In the Ricoh WIM, choose "Administrator Tools" under "Extended Features Settings". The interface to set/change the Remote Installation Password is found under the "Web Service Settings" group:

           

           

          Click the "Change" button and then supply the current password (if applicable; the default is to have no password here), followed by the new password, confirming the entry:

           

           

          This password corresponds with the Remote-Install Password in the Ricoh Deployment applet (highlighted in green, below):

           

           

          From there, the installation should proceed normally. PLEASE NOTE: The 1.5.x line installs onto the Java VM of the device, even if it is SOP. An SOP option from Pharos is underway, and we expect to release it in the first quarter of 2019.

           

          -Scott

          1 of 1 people found this helpful
          • Re: Issue Installing Ricoh 1.5.8 IMFP Software
            Bill Kasper Guide

            I cannot stress enough NOT using the Pharos installer for these.

             

            Rather, install from the WIM, using default admin rights, first the Web Config then the iMFP.  We stopped using the actual installer years ago due to all sorts of unresolved issues.  The hand-install takes little longer, and almost never barfs.

            1 of 1 people found this helpful