2 Replies Latest reply on Oct 3, 2017 10:12 AM by Jeff Geller

    Pharos/printer wakeup process

    Anne Pender Wayfarer

      Some users are finding that it takes Pharos too long (subjective... probably under a minute) to discover that the Xerox MFD that had been asleep is now awake and ready to accept print jobs being released from the associated Omega terminal. Assuming that "make users more patient" is not a viable option, I see these possibilities:

       

      1. Turn off "online state check before printing" for the offending devices (the newest Xeroxes seem more prone to it - I assume they are sleeping more deeply and not responding to checks that previous models did respond to). But this would have the side effect of jobs being "lost" if the printer was actually off or out of order, right? (We have a universal queue, so as long as the job isn't actually released to the printer, they could walk to the next device if this one were really broken.)

       

      2. Don't let the Xeroxes sleep, or limit sleep significantly (9pm to 6am even though most use is in the 8-5 range). Not so eco-friendly (or power bill friendly). I've not found any "sleep more lightly" settings but would be glad to hear of them if they exist.

       

      3. Make the Xerox not claim to be ready (a "warming up please wait" message on the screen?) until it is actually ready and able to respond to the online state check. Doubt this is possible...

       

      4. Make the online state check try more times before it gives up - no idea if this is possible?

       

      5. Customize the "no printer available" message that appears on the Omega to add "if you just woke this printer up, please try again in 30 sec". Possible?

       

      Has anyone else gone down this road and either found a (obvious and accessible by the client without needing to contact IT for job re-release) workaround for jobs being released to really-not-going-to-print devices and being lost, or some hack for options 2-5?

       

      Thanks,

      Anne

        • Re: Pharos/printer wakeup process
          Steven English Guide

          Anne Pender,

           

          Depending on whether or not you are getting SNMP responses at all, you could look at modifying the SNMP rules used to determine whether or not Pharos considers the device to be offline (see community TechNote linked below).  Pharos Support has used SnmpB in the past (thanks, Jeff Geller) to walk the MIBS and see what states are being returned outside of Pharos.  This may be helpful so you do not have to dig through the logs as much so I linked the SnmpB SourceForge project as well.

           

          Regards,

          Steven

           

          TechNote: Checking Device Status

           

          https://sourceforge.net/projects/snmpb/files/

            • Re: Pharos/printer wakeup process
              Jeff Geller Guide

              Hi Anne,

               

              Another option is to modify the SNMP Online State Check values in the registry. The keys are located under the "Print Service" key.

               

              HKEY_LOCAL_MACHINE\SOFTWARE\Pharos\Print Server (32-bit machine)

              HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Pharos\Print Server (64-bit machine)

               

              SNMP Failure Retry Max CountREG_DWORD

              In the case where a printer fails to respond to the server's query about its online state, for example due to networking issues or LPR protocol issues, the Print Server will automatically repeat the query.

              This value specifies the maximum number of queries. If this value is set to 1, the server will give up if there is no response the first time.

              This value must be manually created.

              3
              SNMP TimeoutREG_DWORD

              The amount of time (in milliseconds) that the server waits for a response from a printer when checking that it is online. After this time, the server will retry (if so configured, see "SNMP Failure Retry Max Count" above).

              This value must be manually created.

              2000

               

               

              Once created I believe you will need to restart the Pharos Print Server service.

               

              Thanks,

              Jeff Geller