4 Replies Latest reply on Nov 17, 2017 2:45 PM by Richard Post

    Pharos iMFP for HP not working correctly after latest updates

    Ricky Johnson Tracker

      We recently pushed out the July firmware updates to our printer fleet, and we have been experiencing issues with the iMFP for HP software.


      We've received the reports on several model printers (HP LaserJet flow MFP M630; firmware revision 2403732_013009, released July 15, 2017 as an example).  The one that I'm doing my troubleshooting on is an HP LaserJet flow MFP M525 with the firmware revision of 240372_013007, release July 15th, 2017.  Since upgrading to this firmware release, the iMFP for HP on the device does not show the names for the cost centers.  We were running version 4.3.4 of the iMFP software.  Seeing this, I upgraded the server to 4.4.0 and uninstalled/reinstalled the iMFP software on the device.  Now, in addition to not showing the cost center names, when you select one, it says Signing in and reverts back to the main window not signed in.  Before the 4.4.0 upgrade, I could at least see print jobs, but I would have no idea where it was charging them.


      I rolled back the HP firmware (maintaining version 4.4.0 for iMFP), and I receive an OXPd Application Error "45.00.33 Error: SSL certificate or SSH md5 fingerprint not OK, occurred while communicating with" and lists the HP iMFP server.  I rolled back to version 4.3.4 and have the same issue.


      Any thoughts?



        • Re: Pharos iMFP for HP not working correctly after latest updates
          Ricky Johnson Tracker

          Quick Update: I updated to the newest release of the iMFP for HP (4.5.1) and the software is functional, but if you have more than one cost center, it shows up to provide you with the radio boxes for selection, but the names are missing from them.  If you have one cost center, it displays correctly (and no issues if you have none).


          So, I am now running the newest HP firmware on the device with the 4.5.1 iMFP for HP software and I am at least functioning.



          1 of 1 people found this helpful
            • Re: Pharos iMFP for HP not working correctly after latest updates
              Jeff Geller Guide

              I wanted to add in case others stumble across this community posting..


              There is a note in the Release Notes PDF that comes with our HP iMFP version 4.5.1.


              Known Issues in This Release 

              •  When the solution is deployed to a FutureAmart 4 device using Web Jetadmin, Print Release is not secured by the Pharos authentication agent.  For this release, an administrator will have to manually configure Print Release security using the Access Control page of the embedded web server.

              •  Cost Centers are not displayed correctly on Future Smart 4 devices.  For this reason, Uniprint has been removed from the list of supported solutions.  If cost centers are not utilized, this release will work as expected with Uniprint.


              -Jeff Geller

            • Re: Pharos iMFP for HP not working correctly after latest updates
              Ricky Johnson Tracker

              Final Update:  After working with Jeff, we were able to resolve the issue of the 45.00.xx error.


              After rolling back to the latest FutureSmart 3 version and installing the latest HP for iMFP (v4.5.1), we added a new certificate to each printer.


              For the server that has the HP for iMFP Server software installed, we have an SSL cert as that is also our Print Center.  We looked at the certificate and determined what the Root CA was.  We exported that from the server and imported that Root CA onto each printer.  This removed the 45.00.xx message.  We tried with just the SSL certificate, but it still failed with that one.  Hope anyone else who may have this issue finds some help in this.



                • Re: Pharos iMFP for HP not working correctly after latest updates
                  Richard Post Guide

                  I just ran into this myself, and I thought it might be nice to add a bit more detail.


                  Customer also had their own certificate for Print Center and added the HP iMFP software.

                  Logon to the device worked, but we got the error 45.00.33 certificate error when clicking on Print Release button.


                  We went to the customer certificate being used in the IIS binding for HTTPS/443

                  Clicked on Certification Path and selected each of the certificates in the path and selected the Details tab, then Copy to File...

                  In the Certificate export wizard, saved each certificate in the chain as Base-64 encoded X.509 (.CER) and gave each a location to be saved.

                  Then, on the HP web page, we logged in, went to the Security tab, selected Certificate Management and then under the CA Certificates secton, loaded each of the files into the certificates store on the printer.