2 Replies Latest reply on Mar 23, 2017 2:04 PM by Scott Olswold

    How to Handle "Lost Card Code" from CSGold

    Kurt Albrecht Tracker

      We are using Uniprint 9.0 R2 with Mobile Print 2.1.  On the occasion that we get a non-monetary return from CSGold after we have made a balance request.

      Our current response to our patrons when we get something other than a monetary value is either "$0.00" or "insufficient funds", neither of which is illuminating.

      Has anyone out there got a better way to disseminate the information that we get returned from CSGold?

        • Re: How to Handle "Lost Card Code" from CSGold
          Vincent Thompson Newbie

          Kurt,

          I don't know if this will help or not, but in our environment, we simply fix the lost card code within Uniprint.  If the user has problems with their balance, they contact our help desk.  If they report an unexpected $0 balance, the first question I ask is 'did you just get a new ID?'  If they respond 'yes', I pull their card ID field in Uniprint and interate the LCC up one (the last few characters go from 00=? to 01=?).  I'll test the balance with the billplug command.  I realize you're asking for communication methods and this is fix, so like I said, not sure if this will help or not.

          • Re: How to Handle "Lost Card Code" from CSGold
            Scott Olswold Guide

            Kurt,

            My lexicon may be a bit off, but that would correspond to the "issue code" of the card. Essentially, there's a tacked-on value that begins at 00 and increments based on the number times a student needs to get a new card (I was a space-case in college -- my wife would say that's not changed -- and needed my ID replaced 6 times). If you are storing the card ID in the Uniprint database, you'd need to (either manually like Vincent, or through some automated process) update Uniprint based on what CSGold says is current for the user account. Alternately, you could attempt to validate the presented card with CSGold during login, but that may not work with your workflow or configuration.

            -Scott