3 Replies Latest reply on Dec 1, 2015 10:02 AM by Tim Rhoades

    BP5.1 3.1 Server 2012 R2 hpimfp 404 error

    Tim Rhoades Adventurer

      When I launch http://fman34prnt1/hpimfp/WebLogin.aspx?ReturnUrl=%2fhpimfp%2fConfig%2fDefault.aspx I get a 404 Error. When I go to the collector and do a test on the server configuration, I get all green check marks. I have checked the bindings to and everything looks correct. What am I missing ? This is happening on 3 new 2012 R2 servers ( collectors ) that I just built. Need help ASAP !!!

        • Re: BP5.1 3.1 Server 2012 R2 hpimfp 404 error
          Scott Olswold Guide

          Tim,

          The "Test" function in the Blueprint Server Configuration utility only checks the status of the Blueprint components. The HP iMFP Application Service is an accessory product. First, we need to ensure that your web service is installed:

           

          1. Launch IIS Manager on the Collector.

          2. Expand the Computer > Sites > Default Web Site. You should have an "hpimfp" web service item there (highlighted in the screen shot below).

          3. You should also have an Application Pool named "iMFP Server for HP App Pool". Click on the Application Pool item under the server tree. Mine is shown, selected, below. Your application pool's settings should mirror what I have. You should also see one (1) application using the application pool, which is the "hpimfp" service listed in the graphic above.

          If any of those conditions is not true, then you may need to reinstall the HP Application Service. Also, make sure that you have your prerequisite complete for the server:

          • .NET 2.0 (as .NET Framework 3.5 Features; both the core feature and the "HTTP Activation" option are installed)

          I hope that this helps.

          -Scott

            • Re: BP5.1 3.1 Server 2012 R2 hpimfp 404 error
              Scott Olswold Guide

              Tim,

              You may also be seeing the "404.17" error that talks about how "The requested content appears to be script and will not be served by the static file handler."

              If so, you need to add ASP.NET 3.5 to your Web Services Application Development configuration (by default it is not installed when you add IIS to the server):

               

              1. Launch Server Manager.

              2. Choose Manage > Add Roles and Features.

              3. Go through the wizard until you get to Server Roles.

              4. Expand Web Server (IIS) > Web Server > Application Development.

              5. Select ASP.NET 3.5 and continue (see image below).

              6. When complete, close the Add Roles and Features wizard, restart IIS (either use IISRESET in an administrative command prompt or use IIS Manager), and go back into your /hpimfp web application.

               

              Cheers,

              Scott

            • Re: BP5.1 3.1 Server 2012 R2 hpimfp 404 error
              Tim Rhoades Adventurer

              Thank you Scott. I found the problem. The ASP NET 3.5 box was unchecked in the Roles. Everything works now.