9 Replies Latest reply on Oct 28, 2015 5:58 PM by Jason Watkins

    Cannot Print PCL XL Error         

    Jason Watkins Adventurer



      I have a printer (HP Laser Jet M401dn) set up on Pharos 9.0 through a Windows 7 Pro x64-based release station. Each time someone tries to print a job that is over a couple of pages, the following error is produced (printed).


      PCL XL Error

                Subsystem: TEXT

                Error: InternalError 0x50

                File Name: cheettext.c

                Line Number: 710


      We updated the firmware to it's latest release and re-created the client package with the latest drivers for that printer. I'm not really sure what else to do. HP's web-site suggests adding/removing the printer through add/remove devices, but that isn't exactly possible for Pharos-based printers. Any ideas on what else I can do?





        • Re: Cannot Print PCL XL Error         
          Scott Olswold Guide



          Yep: jettison the PCL6/XL print driver in favor of the PCL5 or PostScript version instead. Personally, I prefer PostScript because it makes for a smaller file size than does PCL5 and it is better with graphics and colors.


          This error (and many like it) are caused by the language's inability to obtain a valid printer model via the driver, owing to the disconnected manner that Uniprint queues (Direct or Held) operate. At its most basic, the PCL6/XL language is full of commands and operators, and the ability to execute some of them is not present on each and every physical device's firmware. So you get an "invalid command" or other such message instead of your print job. On the flip side, PCL5 (and most PJL) use common commands to do what they need to get the job out; ditto with PostScript.


          Short of upgrading printer firmware to support the entire PCL6 command library (usually as a result of case-by-case interaction with the device manufacturer; yes, painful), this is your best bet.


          If you go PostScript, just make sure that your output devices all have a PostScript interpreter.

          • Re: Cannot Print PCL XL Error         
            Steven English Guide



            PCL XL tells me that the printer is having a problem interpreting the PCL 6 spool file from the workstation.  You could look at changing the print processor to WinPrint RAW, or switching to a PCL 5 driver to avoid the issue.  The fact that you are getting the error at all makes me think that the driver itself or its configuration is not fully compatible with the printer make/model that you are using.  Over simplified, the PCL 6 driver is rendering a spool file that the printer appears to be incapable of processing.  Personally, I recommend the HP Universal Print Driver PCL 5 (v5.7.0 - 5.0).  You can test this out by modifying a single workstation client, and after confirming the tests are successful, update your queues and then rebuild packages and redeploy.


            Webinar Recording: Universal Print Drivers  (courtesy of Scott Olswold)

            47:10 Beginning conversation on HP UPD

            49:00 Discusses PCL 6

            51:20 Print driver configuration


            Driver Configuration Summary (with a couple of additions from me)

            1. Always install the versioned driver (the driver that lists the driver name along with v5.7.0, v5.8.0, v5.9.0, etc.)
            2. Under the Advanced tab - Set the print processor to Winprint RAW
            3. Under the Device Settings tab
              1. Disable - Automatic configuration
              2. Disable - Printer status notifications
              3. Disable - Job storage
              4. Disable - Secure printing
              5. Disable - Mopier mode
              6. Set Color Printing Mode: ON for Color & OFF for black and white printing
              7. Set Device Type: COLOR for color & MONOCHROME for black and white printing
            4. Under the Ports tab
              1. Disable the bidirectional printing checkbox




            • Re: Cannot Print PCL XL Error         
              Jason Watkins Adventurer



              Thanks for the great responses. We tried with a PostScript package, and the print error went away, but the whole job will not print. The printer will only print part of a multipage job. This is a problem because people are being charged for the complete amount of the job and not what is being printed. We also tried a completely different printer. Same deal. Anything else we can try?


              Thanks again