AnsweredAssumed Answered

Magtek Card Reader Usage for Authentication on Xerox Work Center 5335 (CentreWare)

Question asked by Jason Clock on Sep 16, 2015
Latest reply on Sep 30, 2015 by Jason Clock

Hello Community,

  I have followed the current IMFP document for the 53XX model using Xerox iMFP 2.6.3 and while keyboard login works, I am unable to get the Magtek 21040145 reader to trigger an authentication event.  I needed to install Xerox's USB card reader plugin in order for the reader to show a green status light as expected.  Prior to the installation, there is a red light (missing driver).  The reader correctly identifies a bad swipe and blinks after a valid swipe on this machine.  I have 4 of the same model and have tried multiple readers.  The card reader is outputting the following...

 

%TRACK1Data?;TRACK2Data?<CR>

 

I have also tried the suggestion Pharos had to add a Line Feed <LF> at the end of the data string.  The reader is configured for keyboard mode.  I need to capture both track 1 and 2 for identification and billing.  The reader configuration works out of the box with our 7835/55 and 5855 Xerox devices which are ConnectKey.

 

Xerox has been less than forthcoming, blaming Pharos despite my question about input string termination characters / requirements.

 

Any suggestions would be greatly appreciated as this is greatly hindering usability due the cumbersome process of entering a user name and password vs a card swipe.

 

Plugin 3.0 from Xerox.  WorkCentre 5325/5330/5335 File Download

Used Firmware 53.30.11 and also a SPAR from our Xerox Analyst 53.32.3

 

Here is the Software Configuration for the Xerox

SystemVersion 53.32.3
Controller ROMVersion 1.205.213
IOT ROMVersion 40.2.0
Finisher B1 ROMVersion 7.3.0
ADF ROMVersion 7.10.0
Fax ROMVersion 1.1.14
SJFIVersion 3.0.18
SSMIVersion 1.16.0

 

Here are the Errors I see in the IMFP Setup....   Charging does work correctly aside from login.  Pharos support said these errors are to be expected, but on our Work Center 3635 (CenterWare), we also are unable to login with Card Swipe.

 

Errors

Could not disable the Custom/Extensible Service Proxy Server. Verify manually that the Proxy server is disabled.

Device does not support Network Accounting setup. Enable and configure Network Accounting/JBA manually

 

Xerox Services

EIP Version:2.0.3

Authentication:Unknown

Registration:1.4.0

UIConfiguration:1.1.0

Access Config:1.0.0

Security Config:1.1.0

JBA:enabled

 

Pharos Settings

Default Application:PHAROS_PRINTLogin Method:USB_AND_KEYBOARD
Verify each Job's cost:false

 

Device Details

Device Name:XC-E4B2DFFirmware Version:53.32.3
MAC Address:<Removed>Serial Number:<Removed>
SNMP Get Community:publicSNMP Set Community:private
HTTP Port:80HTTPS Port:443

 

Thank You,

Jason

 

 

Outcomes