AnsweredAssumed Answered

Ricoh duplex not working for Pro 906EX

Question asked by Richard Chao on May 26, 2015
Latest reply on May 28, 2015 by Scott Olswold

Hi everyone! We are having trouble configuring default settings for two of our Ricoh Pro 906EX's. We are unable to get duplex (Long edge bind) to work even though duplex is set in the default printer settings and Pharos is set to "Copy printer settings". We've tried with these three drivers so far and the setting doesn't seem to stick when packages are installed on client machines:

  • PCL6 Driver for Universal Print (x64) Version
  • RICOH Pro 906EX PCL6 Driver Version
  • Older version of the Universal Driver (Version

We also tried to modify drivers using Ricoh's PDP NX, Printer Driver Editor, as well as modifying them directly w/ 7zip with no luck. Custom modules also didn't work.


Oddly enough setting defaults works perfectly for all of our Aficio Models (MP 5000, 6001, 6002, 7001, and 8001) using their PCL6 drivers


Any ideas? Thanks in advance!