2 Replies Latest reply on Apr 18, 2013 2:54 PM by Jim Gilliver

    Pharos Station connection refused when run from Win 7 Startup folder


      Response to the below mentioned post.


      I've seen this same issue in our environment. For some reason in Windows 7, the applications in the startup folder will run before the release station connects to the network; hence the "connection refused". When you manually launch the shortcut it works fine because you already have network connectivity at that point. To solve this issue we wrote a script and placed in the startup folder, with a timeout / sleep and then it (script) ran the Pharos executable. This solved our auto / startup launch issue.


      'Delay startup of Pharos Release Station

      Set oShell =WScript.CreateObject("WScript.Shell")


      oShell.Run """C:\Program Files\Pharos\Bin\Pstation.exe""",1

      'End of script



      While working on our new Pharos 8.1 Uniprint setup I ran into a rather odd issue with our release station(s)  The Pharos Station installed fine and connected to the server with no problems.  Was able to logon and release jobs fine throughout testing.  Then as one of the final steps I copied the shortcut to the Pharos Station executable into the Startup folder in the  Windows 7 (32-bit) start menu so the program would start automatically on reboot and startup and I found I couldn't connect.  The Pharos screen is there but the message "Connection Refused" is in the field where the station description usually is.  If I close out the instance of Pharos station and start it with the same shortcut but with a mouse click it runs fine, but rebooting the machine yield the connection refused messageevery time.


      I don't see anyone else having a similar problem and wonder if anyone had a suggestion.


      Paul Galvanek - Systems Programmer

      HSLS - Falk Library

      Universityof Pittsburgh

        • Re: Pharos Station connection refused when run from Win 7 Startup folder
          Edmund Greene Wayfarer

          I had this same problem.  I got around it at the time, but since then, Pharos has released an updated version of the Pharos Station so this doesn't happen.  You should make sure you have the latest version by checking here:



          1 of 1 people found this helpful
          • Re: Pharos Station connection refused when run from Win 7 Startup folder
            Jim Gilliver Pioneer

            Just a note about the issue and the fix: a minor mistake in a change to the Pharos Station meant it would not retry a failed connection. If the connection couldn't complete successfully, the Station just reported the error and sat there forever. This bug only affected the very first connection made to the Database Server. With the introduction of the Proxy service, quite often the workstation would log in and run the Station before the Proxy could finish starting up, and so you would see the 'Connection refused'. The updated Station from the link Edmund posted now retries the connection correctly. When this problem was originally encountered, it was initially misdiagnosed as being related to delayed network start, because messing with the delayed start settings in XP often solved (read: disguised) the issue. We (Pharos Support) had a few customers implement a small delay prior to launching the Station before we spotted our mistake.

            1 of 1 people found this helpful