Important Security Update for Mac Popup Client

Version 1

    Important Announcement: A security issue was recently discovered in the Mac Popup client by the Cisco Talos Team. We strongly recommend that all Uniprint customers update their Mac Popup clients to version 9.0.8 to address this vulnerability. This update supports all versions of Pharos Uniprint. Click here for details about this vulnerability and to download the security update.