Lindsay Lamb

Why doesn't the transaction view in Pharos Remote use the correct currency settings?

Blog Post created by Lindsay Lamb on Dec 16, 2013

Pharos Remote is a web application, and as a result it does not use the server's Regional Settings to determine currency format.

 

To change the currency symbol, you need to edit the culture settings in IIS Manager:

  1. Open the properties for the Pharos website
  2. Select the ASP.NET tab
  3. Edit Global Configuration
  4. Select the Application tab
  5. change the Culture and UI Culture settings to the desired value

 

For example, select en-GB for both settings to display currency values in pounds.

 

To adjust the number of decimal places displayed:

  1. Edit Inetpub\wwwroot\Pharos\BusinessAreas\Accounts\Dialogs\ViewAccountTransactions.aspx
  2. Search for this line:
    DataFormatString="{0:C2}"
  3. Change the digit 2 to the required number of decimal places and save the file

Outcomes