Skip navigation
All Places > Knowledge Base & Downloads > Blog > 2013 > August > 20

Close your browser and re-open the status page for the HP 4345 printer. Alternatively, cycle power to the HP 4345 printer.

How do I retain my theme when updating from an older Pharos Omega firmware version (pre-Pencarrow)?

 

The latest Pharos OmegaAdmin tool will not allow me to download the current theme from the Omega Terminals. If the OmegaAdmin tool will not allow you to retrieve the current theme from a Pharos Omega unit, the current Omega firmware is too old - a new theme system was introduced in firmware release 1.4.4 (Pencarrow).

 

In order to restore the theme you must have copies of the existing bmp files that were originally uploaded with the current firmware version. You must then upgrade one unit to the latest firmware and retrieve the default theme using the OmegaAdmin tool included in the latest firmware package.

 

Upon retrieving the latest firmware version you need to the edit the default theme and modify the background etc with the original images.

 

You should then push the new theme using the OmegaAdmin.

 

Detailed instructions on editing, retrieving and pushing themes are included in the latest PharosOmega.pdf file that can be downloaded with the firmware from the Pharos Website:

 

http://www.pharos.com/Support/Terminals/Index.html

In working with Mike P and HP we found that the HP Devices are able to provide us with better logging of issues even after reboots through a Stack Dump.

 

To access those files you would need to browse to the HP devices webpage at http://Device_IP/hp/device/svcErr.log.

 

Mike suggest that issues where you receive 49.xxxx error to gather the file that is produced and name it as the model of the device and serial number of the device if possible before transitioning to him.

When I browse to the Pharos Omega PS150 devices web pages, I notice that the CopyLink has an older version than the SmartHub version.

How can I upgrade the Pharos PS150 CopyLink version?
The Pharos PS150 CopyLink is not always updated during a standard firmware upgrade. This is normal, and clients should expect their PS150 CopyLink firmware to remain at a different firmware revision than that of the PS150 SmartHub.

By default, a Pharos terminal (any iMFP, an Omega PS-150, or Omega PS-200) attached to Pharos Blueprint for Secure Release Here (SRH) does not display the name of the user (also known as "owner") who submitted the print job. However, if utilizing the "delegate printing" ability through the authentication script, the ability to see who owns the print job is necessary. To enable the display of the owner when listing jobs, use the following procedure. This procedure assumes the use of Pharos Blueprint 4.2.

  1. Set up the terminal as you normally would in Blueprint Administrator.
  2. On the Collector or Analyst (whichever is hosting the EDI service), locate the terminal's ".terminal.config" file. In Windows 2003, this would be in C:\Documents and Settings\All Users\Application Data\PharosSystems\Blueprint\TerminalPlugins. In Windows 2008, this would be in C:\Program Data\PharosSystems\Blueprint\TerminalPlugins. For this example, the Omega PS200.1.0.1.terminal.config file will be used.
  3. Move this file to the Blueprint \Bin directory (C:\Program Files\PharosSystems\Blueprint\Bin; on 64-bit systems, start in C:\Program Files (x86)).
  4. In NotePad or other text editor, look for this section:

              <Property ReadOnly="false" Clonable="true" Advanced="false" Hidden="false" Type="boolean">
                   <IniSection>uniprint</IniSection>
                   <IniLabel>show print job owner</IniLabel>
                   <Name>Show Print Job Owner</Name>
                   <Tab>Printer</Tab>
                   <HelpId>120001</HelpId>
                   <Default>false</Default>
                   <Override ProductName="Blueprint">
                        <Property Hidden="true">
                             <Default>false</Default>
                        </Property>
                   </Override>
              </Property>
  5. Edit this section to remove the <Override> group. An edited example is shown below:

              <Property ReadOnly="false" Clonable="true" Advanced="false" Hidden="false" Type="boolean">
                   <IniSection>uniprint</IniSection>
                   <IniLabel>show print job owner</IniLabel>
                   <Name>Show Print Job Owner</Name>
                   <Tab>Printer</Tab>
                   <HelpId>120001</HelpId>
                   <Default>false</Default>
              </Property>
  6. Save this change and exit the text editor.
  7. In a Command Prompt window that is running as an Administrator, navigate to the Pharos Blueprint \Bin directory.
  8. Execute the following command:

    C:\Windows\Microsoft.NET\Framework\v2.0.50727\InstallUtil.exe /TerminalConfigFile="Omega PS200.1.0.1.terminal.config" PharosSystems.blueprint.TerminalPlugins.Ini.dll

    Note that this example assumes that Microsoft Windows is installed to the Windows directory. Also, replace the file name (shown in blue) with the .terminal.config file that has been moved and edited.
  9. Back in Blueprint Administrator, go to Devices > Terminals and select the terminal.
  10. Click its terminal schema tab (in this example, the "Omega PS200 Configuration" tab was clicked).
  11. Find the "Printer" section and enable (check the box for) "Show Print Job Owner" and then click "Apply" to set the change.

It will be a few moments before the terminal gets a refreshed download from the EDI service. However, once it is pushed, the list of jobs displayed after logging in will list the print job's owner.

Note: This knowledge base article mentions a function called "delegate printing." Delegate printing allows a user to print another's job(s). For example, an administrative assistant can be authorized to print his jobs as well as those of the people he supports. This function is enabled through modification of an authentication script along with user modifications in the database. Please contact Pharos Systems Technical Support for a list of prerequisites and how to implement the function should you wish to implement delegate printing.

We've noticed this problem when the SQL 2K8 doesn't have the latest SP. To work around the problem please apply the latest Service Pack to it and it should resolve the problem.

You get the following error in DebugView on the TaskMaster thread which contains the same error seen in the log file mentioned in the Administrator when looking at the failure log for why this fails.

[3076] [2011/04/29 13:10:15 PC04 T007 i TaskMaster] [PeriodEndLogger.LogInternal] Period End Close Progress = (34) Adding Daily Summaries Data.
[3076] [2011/04/29 13:10:16 PC04 T007 e TaskMaster] Exception...
[3076]
[3076] 1) Exception Information
[3076] =============================================
[3076] Exception Type: System.Data.SqlClient.SqlException
[3076] Errors: System.Data.SqlClient.SqlErrorCollection
[3076] Class: 16
[3076] LineNumber: 1
[3076] Number: 515
[3076] Procedure:
[3076] Server: AB-2K2008-BP4-2
[3076] State: 2
[3076] Source: .Net SqlClient Data Provider
[3076] ErrorCode: -2146232060
[3076] Message: Cannot insert the value NULL into column 'DeviceId', table 'psjobs2.dbo.DailyJobSummary'; column does not allow nulls. INSERT fails.
[3076] The statement has been terminated.
[3076] HelpLink: NULL
[3076]
[3076] StackTrace Information
[3076] =============================================
[3076] at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection)
[3076] at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
[3076] at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
[3076] at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
[3076] at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
[3076] at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async)
[3076] at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, DbAsyncResult result)
[3076] at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(DbAsyncResult result, String methodName, Boolean sendToPipe)
[3076] at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
[3076] at PharosSystems.Library.DataLayer.ExecuteNonQuery(DbCommand command, Int32 commandTimeout)
[3076] at PharosSystems.Library.StoredProc.ExecuteNonQuery(Int32 commandTimeout)
[3076] at PharosSystems.OutputManagement.PeriodEndDataLayer.ExecutePeriodEndClose(PeriodEnd periodEnd, Boolean fullClose, PeriodEndSettings periodEndSettings, SetPeriodEndCloseProgressCallback SetProgress)
[3076] at PharosSystems.OutputManagement.PeriodEndManager.ExecutePeriodEndClose(PeriodEnd& periodEnd, Boolean fullClose, IPeriodEndPlugins periodEndPlugins)
[3076] at PharosSystems.OutputManagement.PeriodEndManager.CloseWorker(Object state)
[3076]
[3076] [2011/04/29 13:10:16 PC04 T007 e TaskMaster] [PeriodEndLogger.LogInternal] An exception occurred: Cannot insert the value NULL into column 'DeviceId', table 'psjobs2.dbo.DailyJobSummary'; column does not allow nulls. INSERT fails.

The recommended image size for background images in themes is 640 x 480 for PS100 Omegas and 800 x 600 for PS150 Omegas.

The attached document details the use and limitations of extended characters in banner template files.

Windows may have blocked the replacement file importer executable from running.

Right click on PharosSystems.Core.FileImporter.exe (found in \Program Files\PharosSystems\Blueprint\bin) and select Properties. If it is blocked, there will be an 'Unblock' button displayed (see attached screenshot).

After unblocking the executable, restart the Pharos Systems ComTaskMaster service & Pharos Systems TaskMaster service.

Can I run the WCF on another port?

NOTE: McAfee has a service that was running called "FrameworkService.exe" which uses the same port as the WCF.

It is possible to run WCF on another port.  Here is what you need to get a working WCF/Remote to run on port 8082:

 

WCF:

 

Change all 8081 -> 8082 in Pharos\Bin\WCF\PS.vNext.SvcHost.WinSvc.exe.config
Restart WCF, confirm listening on 8082 via netstat.

 

Web remote:

 

Change 8081 -> 8082 in wwwroot\Pharos\appSettings.config (only one entry)
Restart IIS, test remote

 

Web Remote does not need EDI to run.  
The WCF service is conceptually like a specialized EDI that is exclusive to Web Remote.

This error message will be displayed if you have accidentally plugged the LAN network cable into the port marked PRINTER on the Omega SmartHub. Remove the LAN network cable from the PRINTER port and plug it into the port marked LAN.

1. Make sure the FTP user has read and write permissions on the upload folder that is located in the Pharos Blueprint directory

2. In other cases, Lexmark software can cause the problem. Run file monitor to find out where the error is occurring. The error will be related to "Inetinfo.exe could not find PCinfo.dll" and it will also look into a strange directory - if possible, delete that directory.

See attached screenshot.

When printing to a Canon Print Queue we recieve the following printing error - “Cannot print because the version of the device controller function is old.  Contact the administrator for details”.

How can I resolve this error?

This was most recently seen when using a Canon imageRUNNER C4080; however, please note that it is not limited in scope to this particular Canon model. This can be resolved by making a change to the Printer Driver configuration, see below for details.

Note: This is an error message produced from an interaction between Windows and the Print Driver and not Pharos. The problem is with the configuration of a setting called "Function" being set to 1.0.

 

1. Go to Printer Properties->Device Settings and click on Function.
2. Set it to 2.0 or later.
3. Click OK to commit the change and close the Properties dialog box.

 

The Omega PS150 and the iMFP series devices do not support Stored Value Card readers.The provided DLL's from our website work only with the Pharos PC Release Station.

Occasionally, the following error message appears during an install:

 

"1603: Error installing Windows Installer engine. A file which needs to be replaced may be held in use. Close all applications and try again."

 

This message is generated by Windows, and can be safely disregarded. Simply click OK to proceed. Blueprint will install successfully.

I recieve the error when trying to Import HR Data or add a new ImportConfig file to the Blueprint Enterprise system.

The message being seen is: Error: "Unable to create an instance of the PharosSystems.Core.EntryInstaller installer type."

The below KB Article is a first place to look at a few settings.
https://pharos.custhelp.com/app/answers/detail/a_id/912/kw/912


Below is a link from a web site to obtain there tool that can be used for Windows Server 2008. From an MSDN Blog below is a lot of information on configuration/setup of the "Details about setup for the .NET Framework 2.0 configuration tool".
http://blogs.msdn.com/b/astebner/archive/2006/01/23/516671.aspx


This msdn blog has a lot of good info in it although I have not gone through the whole thing as I did not need the whole SDK to be installed on my server but hopefully this will help sort out the permissions issue that causes the error.

Please see the attached PDF.

Alphabetical sorting in Blueprint Administrator is not supported for any lists containing Chinese characters.

Problem

When attempting to log into the Konica-Minolta iMFP for Blueprint, users will sometimes get this error:

KM iMFP initialization error

and it will persist until the "Pharos for Konica Minolta" service is restarted on the affected Blueprint server.

Cause

This issue occurs because the "Pharos for Konica Minolta" service starts up before the "Pharos Systems TaskMaster" service, which manages the BniService.svc process referenced in the error message. This usually happens during a restart of the server hosting the services. This will affect all Konica Minolta iMFP versions up through, and including, 1.3.0.

Resolution

To permenantly resolve this problem, the Pharos Konica Minolta service must be configured to depend on the Pharos Systems TaskMaster service.

DISCLAIMER: The following instructions require the use of the Windows Registry Editor. While the instructions have been tested and do not result in any loss of function, editing the Registry has the potential to cause system issues. Please ensure that the Registry key referenced has been backed up prior to making any changes. Pharos Systems International, Inc. and its affiliates may not be held responsible for loss of service caused by any procedure described below.

1. Launch the Windows Registry Editor as an administrator.

2. Browse to HKEY_LOCAL_MACHINE\System\CurrentControlSet\services and then find the PharosforKonicaMinolta key. Select it.

3. Right-click within the right-hand pane of the PharosforKonicaMinolta key and choose New > Multi-String Value.

Editing the Registry - Step 1

4. Name it DependOnService and press the ENTER key on the keyboard.

Editing the Registry - Step 2

5. Double-click this new string value entry to edit it.

6. Type Pharos Systems TaskMaster in the Value data field and click OK.

Edit Registry - Step 3

7. Exit the Registry Editor and restart the Pharos for Konica Minolta service for it to take effect.

BONUS: Users familiar with the command-line "sc.exe" utility may perform this in one quick step. Just make sure that the command prompt is in administrative mode and type:

sc config "PharosforKonicaMinolta" depend = "Pharos Systems TaskMaster"

Testing the Change

To test the change, restart the Blueprint server and attempt a login on a Konica-Minolta device. The login will proceed normally.

In the registry, under HKEY_LOCAL_MACHINE\Software\PharosSystems, there are a number of subkeys. If you expand all these out you will find Log subkeys associated with a number of keys. Each of these Log subkeys has a value called TraceLog, which is set to 1 by default. Set each of these to 0 and there will be no more logging from Blueprint. This does not affect the operation of the Tracker in any way.

To find a specific file on the Omega you need to do the following

 

1. Open a command line prompt on your workstation
2. Telnet to the Omega using the following command "telnet <omega ip address>
3. Logon as root and pharos when prompted
4. Type the following command to find the file "find / -name {<filename>} -print
5. Found files will be displayed on screen.

The recovery mechanism failed to automatically reboot the Omega to fix this failed upgrade. Manually reboot and retry the upgrade - this should fix the problem.

 

To check that the upgrade was successful check that the SmartPAD and CopyLink both have correct version info after an upgrade as shown in Omega Administrator. If they don't then reboot the Omega and retry the firmware upgrade.

Answer:

You get this error message if the Cluster isn't prepared correctly, please follow instructions below to fix it:

1. Remove all resources via the Cluster Manager if any.

2. Create a "Print Spooler" Resource

3. In the "Print Spooler Service" add the 'Message Queuing' resource

4. Open the Properties window of the 'Message Queuing' and add following dependencies:

Physical Disk, Network Name

5. Install Blueprint 4.2 on all nodes and once that is completed bring the Resource offline and add following Generic Service to the resources:

A. Blueprint TaskMaster

1. Dependencies: Physical Disk, Network Name, MSMQ, Spooler, SQL (where appropriate if installed on cluster)

2. Service Name: Pharos Systems TaskMaster

3. Use Network Name: True8

 

B. Blueprint ComTaskMaster

1. Dependencies: Blueprint TaskMaster, Physical Disk, Network Name, Spooler

2. Service Name: Pharos Systems ComTaskMaster

3. Use Network Name: True

 

C. Blueprint Event Log Service

1. Dependencies: Physical Disk, Network Name

2. Service Name: Pharos Systems Event Log Service

3. Use Network Name: True

 

D. Blueprint Job Service

1. Dependencies: Blueprint Event Log Service, Physical Disk, Network Name, Spooler

2. Service Name: Pharos Systems Job Service

3. Use Network Name: True

 

IIS Preparation for Windows Server 20008 Cluster

 

1. Open Internet Information Services (IIS) Manager on the physical node that currently owns the resource group created in the "Cluster Preparation" section on page 57. This will be the node on which the service or application is running.

NOTE: If the Default Website is already in use, create a new website that will be used to host the Blueprint web services.

2. Bind this website to the IP Address that was created in the 'Cluster Preparation' section on page 57 of the Install guide. Please do not bind it to the Node 1 / 2's IP Address. This is the IP Address of the Client Access Point configured when creating the service or application.

Known issue with the Job Service

 

If the Collector is installed in the cluster enviroment, you may get the following error in the Event Viewer for Applications when you start the 'Job Service' service:

 

Service cannot be started. System.Configuration.ConfigurationErrorsException: Invalid element in configuration. The extension name 'webHttp' is not registered in the collection at system.serviceModel/extensions/behaviorExtensions. (c:\program files (x86)\pharossystems\blueprint\bin\pharossystems.blueprint.securerelease.jobservice.exe.Config line 17) at System.Configuration.BaseConfigurationRecord.EvaluateOne(String[] keys, SectionInput input, Boolean isTrusted, FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult) at System.Configuration.BaseConfigurationRecord.Evaluate(FactoryRecord factoryRecord, SectionRecord sectionRecord, Object parentResult, Boolean getLkg, Boolean getRuntimeObject, Object& result, Object& resultRuntimeObject) at System.Configuration.BaseConfigurationRecord.GetSectionRecursive(String configKey, Boolean getLkg, Boolean checkPermission, Boolean getRuntimeObject, Boolean requestIsHere, Object& result, Object& resultRuntimeObject) at System.Configuration.BaseConfigurationR... "

 

The solution is:

 

1. Open Command prompt as an Admin

2. Go to C:\WINDOWS\Microsoft.NET\Framework\v3.5

3. Run WFServicesReg.exe /c

-------------------------------------------------------------------------------------

 

Please check the attached log file for further details.

The PS60 does not support DDNS so if the printer is configured with DDNS the PS60 will pass it thru to the DDNS server. This can cause confusion as the printers name will be mapped to the PS60 Printer IP Address (default: 192.0.2.2) rather than the LAN IP address that the PS160 has.

The printer must have its DDNS client turned OFF!

This happens when the person collecting the cash logs on using a system administrator account that is not in the Pharos Database as a 'cash collector.'