When installing Pharos Blueprint and completing the step within the Server Configuration utility, the following message appears (see example error message below):

Blueprint Install Configuration Error - IIS in 32-bit mode

 

"There was an error while configuring the Pharos Blueprint Enterprise Service. Start registering ASP.NET scriptmap (2.0.50727) at w3svc/1/Root/PharosSystems/. Error when validating the IIS path (w3svc/1/Root/PharosSystems/). Error code = 0x80040154 The error indicates that IIS is in 64 bit mode, while application is a 32 bit application and thus not compatible."

Further, when clicking OK in the error dialog box, the Blueprint test fails for both the Tracker and EDI Web Services.

The problem is due to the PharosSystemsAppPool not running in the 32-bit address space on a 64-bit system. Microsoft Windows IIS Server 7 running on a 64-bit platform will allow both 32- and 64-bit application pools (Windows 2003 64-bit only allows one or the other, not both). By default, however, the 32-bit function is not enabled.

 

In order to allow a 32-bit application pool, run the following in an administrative command prompt (as one line; your browser window may break the line):

 

%windir%\system32\inetsrv\appcmd set config -section:applicationPools -applicationPoolDefaults.enable32BitAppOnWin64:true

 

and then follow up with:

 

%windir%\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis -i

 

which reinstalls ASP.NET in 32-bit mode as well. You should not have to issue a reset of iis (iisreset), but it won't hurt if you do.