When I try to print to our Pharos Server, from the client's computer I can't print, it says it can't talk to the server.  If I add our domain to their DNS Suffix, it works.  What steps can I take to resolve this issue by either configuring the Pharos Popup Package to use FQDN of the server or the servers IP Address?

The Pharos Popup Package gets built from whatever server name is used in the Pharos Administrator > System > Server Configuration > Host Name.  More than likely, you have the simple name there, and also in the Pharos database.  You can confirm this by going into SQL Server Management Studio and executing the below SQL query.

use pharos
select * from servers

 

Take the information you find in the database, and create a REG_SZ key in the registry named MachineName under 'HKEY_LOCAL_MACHINE\SOFTWARE\Pharos' and add the value you found from the DB query, which is more than likely the short name.

NOTE: On a 64-bit server, use the Registry path 'HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Pharos' or the edit will not work.

 

You can then go into Pharos Administrator and change the Host Name value to the FQDN.  From this point on, all installed packages will use the FQDN rather than the short name for resolution.