CAUSE

This error occurs because of a defect in the uninstaller program. osql.exe is a program used for connecting to databases, and comes with Microsoft SQL Server. Depending on your configuration, the Uniprint Installer may or may not install a copy of osql.exe within the Pharos installation directory. The uninstaller decides whether to use the copy in the Pharos installation directory or the copy in the Microsoft SQL Server directory. If the uninstaller uses the copy in the Pharos installation directory, it removes that copy when it has finished uninstalling the Pharos Database. However, due to an defect in the uninstaller, it actually removes the copy of osql.exe that it uses, wherever that copy is located. This error generally occurs if all the letters in the computer's name are in upper case.

SOLUTION

If the problem is discovered only after the uninstaller has been run and osql.exe has been deleted, the only remedies are to copy osql.exe from a known-good copy of the same version of Microsoft SQL Server as is installed or to uninstall and re-install Microsoft SQL Server.

If the problem is anticipated, the removal of osql.exe may be remedied by finding the file before running the uninstaller, making a copy of the file, running the uninstaller, then replacing the file from the copy.

An alternate solution involves editing the Windows Registry. On the Principal Server computer, the registry value HKEY_LOCAL_MACHINE\SOFTWARE\Pharos\Database Server\Host Address contains the name of the computer. Edit the value to replace the upper case letters with corresponding lower case letters, while taking care to ensure that the value is not changed in any other way. This causes the uninstaller to expect to find osql.exe in the Pharos installation directory; copy osql.exe there, as described in the solution to the first problem described in this article, then run the installer. This alternate solution will not work if the registry value is absent because the Database Server has already been uninstalled (as is likely to be the case if this is a second attempt at uninstalling after failing to find the file the first time), nor if the computer's name does not contain any letters at all.

The uninstaller issue affects computers named with lowercase letters differently.  Please see this related article for details.