The Pharos Station is trying to start either before the Pharos Database Proxy service is running, or before the Windows network layer has started. A bug has been identified in the Pharos Station that causes failures at startup time to be fatal instead of recovering as in earlier versions.

In some cases, it may be enough to edit a group policy setting that instructs Windows to wait for the networking before allowing users to log on:

  1. Run gpedit.msc and navigate to Computer Configuration > Administrative Templates > System > Logon.
  2. Set the policy "Always wait for the network at computer startup and logon" to Enabled.

If the Station still starts before the Pharos Database Proxy service, the 'Connection refused' error will be displayed. This can be avoided by using a batch file to ensure the service is started first.

  1. Open the Services tool (services.msc).
  2. Set the Startup property of the Pharos Database Proxy to Manual.
  3. Replace your startup shortcut with a batch file containing the following two lines:
    @net start psdatabaseproxysvr
    @start "" "%programfiles%\pharos\bin\pstation.exe"
    
    Replace the path to the Station if necessary.

A solution is currently being worked and and the fix will be posted on the Pharos Support web site.