Use PS60 version 1.1.4 for a new Blueprint 4.2 install.

 

Symptom:

When connecting a PS60 to Blueprint Enterprise 4.1 or 4.2, the terminal's type shown in Blueprint never changes from "Generic" to the correct PS60 terminal type.

 

Resolution:

You are using an older PS60 software (e.g. 1.1.3 or older) that does not support automatic terminal type updates. Upgrade your PS60 to the latest version of PS60 software (1.1.4 as of September 10, 2010).

The PS60 software is available at: http://www.pharos.com/support/downloads/terminals/omegaPS60.html