This is a know issue in Vista.

 

See:  Microsoft Help and Support - Article ID: 947236

 

1. Click Start , type gpedit.msc in the Start Search box, and then click cmd in the gpedit.msc list.
If you are prompted for an administrator password or confirmation, type your password or click Continue.
2. Under User Configuration, expand Administrative Templates, expand Control Panel, and then click Printers.
3. Right-click Point and Print Restrictions in the right hand pane, and then click Properties.
4. Click Enabled.
5.If you do not want to restrict users to specific print servers, click to clear the Users can only point and print to these server check box.
6.If you do not want to restrict users to print servers in their own forest, click to clear the Users can only point and print to machines in their forest check box. You do not have to add any servers when you click to clear this check box.
7. In the Security Prompts area, select Do not show warning or elevation prompt in the When installing drivers for a new connection box and in the When updating drivers for an existing connection box. These settings enable the print drivers to be installed without credential or elevation prompts.