This is usually the result of a mismatch between the name of the machine as identified in the WCF config file and the name encoded on the self-signed certificate automatically created on the WCF server. You will need to compare these:

 

1. To review the WCF Config File

 

Open the following file:
\Pharos\Bin\WCF\PS.vNext.SvcHost.WinSvc.exe.config

 

Somewhere close to the bottom of this file you will find a section:  <serviceBehaviors> In there will be the machine name that was recorded on install... in two separate places regarding "serviceCertificate".

 

2. To review the Certificate details:

 

Open an MMC console
File > Add/Remove Snap-in
Click Add, then select Certificates from the list of standalone snap-ins (set it to manage Computer Account, Local computer) Click OK to open the Snap-in

 

Under Trusted Root Certification Authorities > Certificates you should find a certificate entry for the machine name. 

 

The likely scenario is that the certificate details do not match the entry in the config file, specifically that one of these has the FQDN or something similar while the other does not.

 

Edit the config file changing the two entries in the config file to match the certificate detail.

 

3. Open the following file:
\Pharos\Bin\WCF\appSettings.config

Check to make sure this line has the correct name as well and matches what the certificate was generated for and/or the FQDN that the server is using or the common name if it is using this instead:
<add key="serverAddress" value="YourServerNameHere"/>

 

3. Restart WCF and Remote, and try logging in again.

 

**Additional logging of the WCF Service can be done by following the attached text file on how to enable logging on the WCF service and determine further where the problem may be. You should contact Pharos Support with additional error messages and forward to us a copy of this log file that was produced.